This incident has been resolved the page loading, user registrations, and login should be functioning as expected.
Posted Nov 21, 2023 - 01:58 UTC
Update
We are continuing to investigate this issue.
Posted Nov 21, 2023 - 01:32 UTC
Update
We are continuing to investigate this issue.
Posted Nov 21, 2023 - 01:16 UTC
Investigating
We are aware that users on our websites are currently experiencing difficulties with webpages loading, and signing up or logging in to their accounts. We understand the importance of a seamless user experience, and we apologize for any inconvenience this may be causing. Our engineering team is actively investigating the issue to identify the root cause and implement a solution as quickly as possible. We prioritize the security and accessibility of your accounts, and we are working diligently to resolve this matter.
Posted Nov 20, 2023 - 12:00 UTC
This incident affected: Websites (https://www.teach.org/, https://dallasftworth.teach.org/, https://houston.teach.org/, https://connecticut.teach.org/, https://northcarolina.teach.org/, https://colorado.teach.org/, https://southcarolina.teach.org/) and API.